[H-GEN] DNS and Sendmail

Hilton Travis QuarkComputers at email.com
Mon Apr 10 19:41:29 EDT 2000


[ Humbug *General* list - semi-serious discussions about Humbug and ]
[ Unix-related topics.  Please observe the list's charter.          ]

Hi Bruce,

> QuarkC>  modem  - galahad.quark-au.com.local -
> albatross.quark-au.com.local
> QuarkC> 56kbps  - Mandrake 7.0.2, 2.2.14     - MS Windoze 2000
> Pro, Outlook 2000
> QuarkC> dynamic - 192.168.100.1              - 192.168.100.11
> QuarkC>
> QuarkC> galahad.quark-au.com.local is also known as news, ns1 and mail
> QuarkC>
> QuarkC> galahad named[18159]: sysquery: findns error (NXDOMAIN) on
> QuarkC> galahad.100.168.192.in-addr.arpa?
>
> NXDOMAIN, as per RFC2136, is defined as:
>
>               NXDOMAIN    3       Some name that ought to exist,
>                                   does not exist.
>
> Further explanation is also provided in RFC2308, ie:
>
>    Name errors (NXDOMAIN) are indicated by the presence of "Name Error"
>    in the RCODE field.  In this case the domain referred to by the QNAME
>    does not exist.  Note: the answer section may have SIG and CNAME RRs
>    and the authority section may have SOA, NXT [RFC2065] and SIG RRsets.
>
> QuarkC> I *thought* my DNS was set up correctly - obviously I
> QuarkC> screwed something up. I get the same error as above when I
> QuarkC> try to lookup an IP with nslookup on the Windows box
> QuarkC> (albatross).  I have no idea what this NXDOMAIN error is.
>
> You will need to set up the appropriate reverse zone on your nameserver.
> A useful guide for this is available at:
> 	http://www.apnic.net/db/revdel.html

I now have my sendmail up and running.  Thanks to all who helped.  I decided
to scrap it and start again - I installed the 8.10.0 tarball, and worked on
it line-by-line until it made some sort of sense to me.  Sendmail is now
sending mail fine, and fetchmail is running in daemon mode to check for mail
regularly.  WOOHOO.

I am, however, still having some DNS problems it looks like.  I for some
reason cannot do reverse lookups any longer.  I don't remember having
difficulties with this before, seems I have screwed something up lately.

This is my named.conf file:
options {
        directory "/var/named";

        forwarders {
                203.2.75.132;
                203.2.75.108;
        };
};

zone    "." {
        type hint;
        file "named.ca";
};

zone    "0.0.127.in-addr.arpa" {
        type master;
        file "0.0.127";
};

zone    "quark-au.com.local" {
        type master;
        file "quark-au.com.local";
};

zone    "100.168.192.in-addr.arpa" {
        type master;
        file "100.168.192";
};
      -=-=-=-=-=-=-=-=

This is my 0.0.127 file:
; /var/named/0.0.127
; for quark-au.com.local
;
@     IN   SOA  galahad.quark-au.com.local.  root.quark-au.com.local. (
           2000041001;  serial
           10840;       refresh
           3600;        retry
           604800;      expire
           86400;       default_ttl
           )
      IN   NS      localhost.
1     IN   PTR     localhost.


Are these files any help to those who know more than I - I have looked at
this for too long, and something obvious is being overlooked.

Regards,
Hilton Travis


--
* This is list (humbug) general handled by majordomo at lists.humbug.org.au .
* Postings to this list are only accepted from subscribed addresses of
* lists 'general' or 'general-post'.



More information about the General mailing list