[H-GEN] DNS and Sendmail

Luke Grant luke.g at uq.net.au
Mon Apr 10 00:00:18 EDT 2000


[ Humbug *General* list - semi-serious discussions about Humbug and ]
[ Unix-related topics.  Please observe the list's charter.          ]

ummm......have a look at your firewall.
from what you just said then it could well be that you are blocking
yourself out and that your sendmail and dns are just unreachable.

Luke



On Mon, 10 Apr 2000, Hilton Travis wrote:

> [ Humbug *General* list - semi-serious discussions about Humbug and ]
> [ Unix-related topics.  Please observe the list's charter.          ]
> 
> Hi Luke,
> 
> > > I have been trying to set up my Linux box to process my mail.
> > > I want to use fetchmail to suck mail from my ISP and then have
> > > Outlook (on my main machine) connect to my Linux box to both
> > > send and receive mail.  I have managed to struggle through
> > > most of the sendmail info I have found, but cannot get it to
> > > accept a connectin from Outlook to send mail through it.
> > >
> > > My network setup is as follows:
> > >
> > >  modem  - galahad.quark-au.com.local - albatross.quark-au.com.local
> > > 56kbps  - Mandrake 7.0.2, 2.2.14     - MS Windoze 2000 Pro, Outlook 2000
> > > dynamic - 192.168.100.1              - 192.168.100.11
> > >
> > > galahad.quark-au.com.local is also known as news, ns1 and mail
> > >
> > > I have got DNS (named) and sendmail running on galahad.  When albatross
> > > connects to galahad to send mail, albatross reports that "Your
> > > SMTP server has not responded in 60 seconds".  As soon as Outlook
> > > (albatross) attempts to send mail via mail.quark-au.com.local (galahad)
> > > I get the following error in /var/log/messages:
> > > galahad named[18159]: sysquery: findns error (NXDOMAIN) on
> > > galahad.100.168.192.in-addr.arpa?
> > >
> > > I *thought* my DNS was set up correctly - obviously I screwed
> > > something up.  I get the same error as above when I try to lookup
> > > an IP with nslookup on the Windows box (albatross).  I have no idea
> > > what this NXDOMAIN error is.
> > >
> > > Any help would be appreciated.  I really want to get this sendmail
> > > thing figured out, and I think it has something to do with me
> > > screwing up the DNS.
> 
> > Firstly i would test that sendmail is running properly. If you ps auwx
> > |grep sendmail, some distributions of sendmail will tell you if they are
> > accepting connections on port 25. If this doesn't help try telnetting to
> > port 25. If this is not up then start again....sendmail is not working.
> >
> > once you have port 25 up...test port 110. If both of these are up then try
> > setting your email app to look to the IP rather the domain name.
> 
> Well, I had noticed that ps -eaf | grep sendmail had said "accepting
> connections", and ps auwx says "sendmail: accepting connections on port 25".
> I tried to telnet to 192.168.100.1 25 and I get no connection - looks like I
> have screwed up sendmail as well as my DNS!
> 
> I'll have another look at my galahad.mc file - I'll post it if I can't work
> it out.
> 
> Thanks for your help so far,
> 
> Regards,
> Hilton
> 
> 
> --
> * This is list (humbug) general handled by majordomo at lists.humbug.org.au .
> * Postings to this list are only accepted from subscribed addresses of
> * lists 'general' or 'general-post'.
> 

=====================================================
Luke Grant
mob#: 0413 317 952
mail: Luke.G at uq.net.au
=====================================================


--
* This is list (humbug) general handled by majordomo at lists.humbug.org.au .
* Postings to this list are only accepted from subscribed addresses of
* lists 'general' or 'general-post'.



More information about the General mailing list